Jump to content

4K EFI Test Rig - IAC Valve


Banjo
 Share

Recommended Posts

Quote

The next step, is to move up a 200mm dia. disk, so that I can space the magnets around the circumference, with a slightly larger distance between them.

The 200mm x 6mm thick aluminium disk arrived in the mail this afternoon.  I purchased the blank on ebay, from a company in Victoria, who mills them.  Very good quality & service !  Bit over $ 21.00 + postage.

 

image.png.af562b5ff8359453538c2d139ae6790f.png

 

So it's a "blank canvass", & not having any CNC equipment, I had to go back to school, to "geometry days", to prepare this plate for drilling.  I experimented with the 150mm dia. one I made previously, so had a plan.   If anyone, wants to replicate this, it is quite easy. Just takes a bit of time & patience.  It is not one of those activities you can rush; because if you stuff it up, then you are back to "square one".

The first thing we need to do, is find & make the centre of the aluminium disc, as that is absolutely crucial, if it is all going to work.

I tried all geometrical ways to find the centre, but each time, the centre was off a mm, or two.  My final technique required no tools at all, or geometric instruments really.

Technique:  

1.  First clean & dry the disc carefully, to remove any oil.

2.  Lay the disk on a clean sheet of A4 white paper. ( 200mm dia. disc, is slightly narrower, than the A4 sheet.

3.  Holding the disc down hard against the paper, run a Artline pen (0.4 or 0.5) around the edge of the disc a couple of times.

4.  Remove the disc, & taking a pair of large, sharp siccors; cut around the edge of the circle on the sheet of paper. When you cut the  paper, cut carefully around the inside of the line, rather than the outside.  The result should be a white circle with little or no remains. of the line you marked.

5.  Lay the paper flat, & carefully fold it in exactly half. Rub along the crease line, while folded, so the crease line is very "distinct".

6.  Take the semicircle of paper, & again fold it exactly in half; & again, ensure the crease line is very defined.

7.  Now open up the folded circle of paper, & the point where the crease lines cross, is the exact centre of the circle.

image.png.59e3edc7d3aa02332687a01779633773.png

8  Draw a straight line across the circle of paper, on both of the crease lines.

9.  Using the centre point, scribe a circle around the circle, just in from the circumference edge.  In my case that was 10mm. 

10.  Take the biggest protractor, you can get hold of, & placing the cross hair point on the centre of the circle, mark the point around, at the number of degrees you need, which will depend on your preference.  I wanted a 36 tooth/magnet trigger wheel, so each mark was spaced at 10 degrees. 

11.  What you finish up with is a circle of paper, that looks something like this.

image.png.de84225850911ea8a07ebfebea1ab06c.png

 

12.  Now, take the circle of paper & lay it on the disk. I now becomes obvious why I suggest cutting on the inside of the circle line intially, as it is extremely difficult to centre it, if the paper is just overhanging the edge of the disk.

13.  I suggest doing this, with the disk & paper hanging slightly over the edge of your table or desk; so that when you have is perfectly centred, you can apply 4 or 8 pieces of clear sticky tape, that sticks to the underside of the disk.

image.png.e6af7de1a9bc0042be3f9272aa973db4.png

14.  So that's it !  Now place the disk, & paper template on a bench, & with a small, sharp centre punch, carefully "centre punch", the central point of the disk, & all the peripheral holes, that are to be drilled for the magnets.

image.thumb.png.7176b7c8000b1db13f68c64f9633b019.png

15.  Drilling the holes should ideally be carried out, using a drill stand, with the aluminium disc, clamped down. Always start off with a small drill, & then keep enlarging them, until you get them to the size you need.  The outer ring of holes, where the magnets are to be fitted, should be drilled about 0.5mm undersize, to the diameter of the magnet; so the magnets can be pressed into the alumium disk.

image.png.91596e544852102100d85e83bdef7376.png

When I get to the next stage, I'll post the results.

P.S. Anyone wanting to know how Hall Effect sensors work, would find this article interesting.  https://www.electronics-tutorials.ws/electromagnetism/hall-effect.html    Our application here, is passing the pole of the magenet, across the face (sideways detection) of the Hall Effect sensor.

Cheers  Banjo

 

  

Edited by Banjo
Link to comment
Share on other sites

Members dont see this ad

Over the weekend, I experimented a little more & resolved a couple of issues.

The 12mm dia. Hall Effect sensor, I was using (NJK-5002C) is certainly a useful device for proving, that this experiment will work. It reacts to a south pole magnet face only.  I had played with a 8mm dia. similar Hall sensor, that turned out, to switch to both north & south poles, & even to the aluminium plate if it was very close ? ? ?

image.png.46cc1a40be73756c088e962b1be242e0.pngIt It was a LJ8A3-2-ZBX.  I gave that one away, as being useful, or appropriate for this application.

So I now have two NJK-5002C Hall sensors side by side.  One counting the 18 off 5mm dia. south pole magnets around the peripheral of my 150mm aluminium disk, without any missing magnet/tooth.

image.png.79a6b9bc75ee46114d9e5412e085231a.png

 

The second Hall sensor, is 20mm further inboard on the disk, in-line with the first sensor & disc centre point; but only picks up the one "sychronisation south pole magnet", per crankshaft revolution.

I hooked the dual channel CRO up to the two sensors, & they were clean, & no missing pulses at all, with the engine on the stand, run up to a bit over 3000 RPM.  With the 10mm larger dia. magnets I will be using later, on the 200mm disc; the magnetic field will be stronger & I can probably incease the air gap between disk/magnet face, & the sensor face.  Currently running at about 2mm, but with a  larger & stronger magnet, it should be possible to achieve gaps of 3-5mm.  The rare earth magnets, come in a multitude of difference sizes, & there are three (3) commonly available strengths; of N35, N50 & N52.  N52 is the strongest.

I did resolve another issue I had, which was "air gap" variance, as a result of slight run-out of the aluminiun disc, in the "planar mode" (across the face of the aluminium disc).  The 150mm & 200mm aluminium disks I am using are 6mm thick.  They are very rigid.  The are mounted primarilary; via the crankshaft pulley centre bolt.   There are additional threaded holes in the crankshaft pulley for either attaching a "puller", to remove the pulley, or to sandwich an additional pulley, as in the case of the 5K engine, which had up to three (3) pullies, depending on it's application.  I have used these to locate the aluminium disk, "rotationally". However, when adding a nut to the studs, is distorts the aluminium plate, ever so slightly, however well you try to shim it at the back. I decided to remove the nuts, & the air gap then did not vary at all.  I could cut the studs down a bit, put a screwdriver slot in them, & "thread locker" them in, & they will still act as locators of the trigger disc. Alternatively, I could dispense with them altogether, & just fit a slightly longer crankshaft location key, in the keyway; & file a small keyway in the aluminium disk, at the point where the synchronisation pulse appears at it idea position, (encoder wise).

A lot of ECU decoders, don't like the sychronisation pulse occurring at the same time as any other event. I may have to move the sychronisation magnet, so that it occurs between the pulses on the outer edge, rather than in line.  Easy fix, if necessary.

I have discovered, in recent days, that there is available, a Hall Effect sensor, for automotive applications; with two (2) sensors built into the one housing.   

 https://www.efisolutions.com.au/dual-channel-hall-sensor-suits-taarks-hall-kits

image.png.136222c1d0e383a927c167a9c7e6327c.png

 

One sensor provides an output, when facing a "south pole" of a magnet, & the other, provides a sencond output, when a north pole face comes along.  This provides a great opportunity, to simplify the system, with just two sensors, rather than three, for sequential ECU operation.  It would simply involve fitting one of the magnets, on the peripheral of the disk with a north pole. (press the magnet it the opposite way around).  This would result with a synchronisation pulse, once per crankshaft revolution, from the sensor reacting to the "north pole".  The second Hall Effect sensor, within the housing, would react to 35 of the 36 magnets around the peripheral, of the disk. It's output would in fact appear to have to a "missing magnet".  However, if the outputs of both sensors were "OR'd" together, the result would be a continuous string of pulses, with no missing pulse at all.

One other thing I discovered, in recent days, is that the Hall Effect sensor, inside the sensor housing, are usually much smaller in area that the cross sectional area of the sensor housing itself, & is not necessarily at the centre of the sensor face,  I broke one sensor accidentally, & discovered this.

image.png.46793575ffcecb93f6e77fb6ee907d23.png

So very pleased with progress to date, & now it is time to replicate this on a 200mm aluminium disk, with maybe just two (2) physical sensors, instead of three.  For Waste Spark/Batch Injection, you could get away with just one sensor housing, with two (2) indivual sensors therein.

image.png.0ab98da194f391aedc9e760b94e6fc0d.png

1.  Crankshaft Speed Sensor  CKS

2. Camshaft Positianal Sensor CAS

3.  Crankshaft Synchronisation Sensor  SYN

Cheers Banjo

 

 

 

Edited by Banjo
Link to comment
Share on other sites

  • 4 weeks later...

Well the 200mm dia. aluminium trigger disk is working better than I could have dreamed of.  The TAARK dual Hall Effect sensor, is far more sensitive  than the "ebay" sensors, I had been experimenting with.  Because the dual Hall effect sensor is so sensitive, to both North & South pole magnets, with air gaps achieved of 3-5mm; there has been no need to revert to larger diameter 10mm rare earth magnets.  In fact if I had used them, the break in the pulse train, as the sensor passes from one magnet to the next; would have resulted in a very short break between pulsing signals.  I've stuck with the 4mm dia. magnets, & pressed the 36 magnets into the disc, as follows . . .

17 south pole: 1 north pole: 17 south pole: 1 north pole.

image.png.68ac816af7992d1a59bd8c11e026bdf9.png

The outputs from the two (2) north & south pole sensors are "OR'd" together, with the 34 pulses (2 x 17) from the south polev magnets; to produce a continuous unbroken string of pulses, that will be used for high resolution of crankshaft rotational speed calculation. The two (2) north pole magnets, spaced exactly 180 degrees apart on the alumimium disc, will produce a total of four (4) pulses, for each full cycle of the engine, whiich is 2 revolutions of the crankshaft, or 720 degrees. The pulse from these two (2) north poles will produce 4 equally spaced pulses 180 degrees apart, for every full cycle, or two (2) crankshaft revolutions.  These can be used, in conjuction with the Camshaft Position Sensor pulse, to direct the outputs sequentially, based on the 1-3-4-2 firing order.   If it was a 6 cylinder engine, the magnets would be pressed into the aluminium disc, as   11 south, 1 north, 11 south, 1 north, 11 south, 1 north.  Again a total of 36 magnets, but just arranged differently.

image.png.1c461b3c5f559fee699fd42d9e477af5.png

 

Nice clean square pulses on the CRO, from the trigger wheel at about 1500 RPM

image.thumb.png.3c9443dd5594fa38df0c847dd0169972.png

Opto Couplers X 3, with "ORing" circuitry for continuous stream of "speed" pulses, With a few LEDs, so I can see clearly, what is happening.

image.png.1c578fedb324c0bd22dec5db8ef00808.png

image.thumb.png.bef0d931c692d879b7e743b4ead31d23.png

All good fun, & almost time to start a "bit of coding", to tie it all together. 

Cheers  Banjo

Edited by Banjo
Link to comment
Share on other sites

  • 1 month later...

Haven’t posted to this thread for a while on this project, as Christmas was in the midst, of that period.

However, I’ve been doing a lot of design work on the bench, after I proved that the pulses generated by the aluminium multi-magnet trigger wheel, were reliably & worked well, on a working/running 5K engine.

My next stage was to see if it was possible to decode the signals I had produced into actually running the engine, albeit, with a fixed advance of say 10-12 degrees.  For this exercise, I needed to use the camshaft, CPS (camshaft position sensor), which was available on my 5K engine, but not on my bench; unless I built a little mechanical electric motor driven wheel, with another adjoining disc, running at half speed, to produce the CPS signal / pulse.

Not wanting to go to all that “mechanical” trouble, I came up with an idea, that worked perfectly.  I added a single additional magnet; mounted slightly inboard on crankshaft aluminium trigger wheel/disc.  It produced a single pulse once per revolution, when, really; I needed one pulse every two (2) revolutions. I passed the single pulse through an IC that provided frequency division by two; & “voila”, it worked perfectly, with a single pulse for every two turns of the crankshaft mounted trigger wheel.

It didn’t take long to produce a circuit, that provided four (4) individual sequential pulses; exactly 180 crankshaft degrees apart.  I only needed 3-4 dedicated ICs, to perform this function.

image.png.3a6a9c3744e23ee5c1b5bc6c1735f07b.png

The little electric motor I had on bench has a speed controller on it, so I can run the motor for cranking speed to about 3500 RPM.  The waveforms on the C.R.O. (Cathode Ray Oscilloscope), looked clean & precise.

image.png.9fedccaada5a74131678dbb8b9ea1169.png

 The last stage of this exercise/experiment, was to fire four (4) spark plugs, sequentially, before I head out to the garage to hook it up to a real running engine.  For this I needed a precise pulse width to charge & fire the COPs (Coil On Plug) ignitors .

The particular COP I’ve been using is a Denso model 90919-02240, commonly fitted to the Toyota Yaris, & by all accounts favoured by a lot of motor sport people who have converted early Toyota & Nissan engines over to COP coils.

After I googled, I managed to find a number of people who have played with this particular COP, to determine, a range of trigger/charging pulse widths, to cater for a range of 12 volt battery voltages from 7 – 15 Volts DC.  This is necessary, so an ECU, can produce a pulse width to charge & trigger the COP, with the ideal pulse width, based on the battery terminal voltage.  The obvious need for this would be a cold winter start, where battery voltage, under cranking, could be too low, to produce a reliable & full strength spark to fire & start the engine.  A wider pulse would be required, to “fully charge” the COP coil, before it is discharged, to induce a HV voltage in the secondary coil.

The pulse width figure, for this model COP, for a 12 volts supply, appears to be about 3.2 – 3.3 milliseconds, from tables I’ve seen on the net, where others have carried out detailed testing of this COP model.

My repeated tests here, seemed to agree.  With a battery voltage of 12.59 Vdc, the ideal pulse width, where the coil charge just reached saturation was about 3.3 msec.

image.png.7c4d7b64c1261ed45a8495266ae0d75a.png

So I build four (4) little circuits, to each produce a 3.2 msec pulse, using a 555 timer; & hook the little test system up to 4 off spark plugs, all gapped the same, on my bench.

Again; “voila”, I then had four (4) spark plugs firing sequentially, on my bench, without a mechanical distributor or micro processor ECU in sight; or involved at all.

I had the four (4) new spark plugs, fitted to a K series head upside down, on the bench.

image.png.0da23edb00fc2d7dc0df821cf4b2a71a.png

I turned off the lights in my workshop, & viewed the spark plug “arcs”, at close quarters with a magnifying glass.  On one plug, the spark looked a slightly different colour to the remaining other three; & did not appear to be as “intense”.

My CRO indicated all four COPS were receiving a pulse with width of exactly 3.2 milliseconds.  I checked all the connections & battery voltage fed to pin 4 of each COP, which were OK.

So I swapped two adjacent COPs around, one being the one, that was not as intense.

Strangely, the  spark plug at the position which had the weaker spark, moved to the relocated COP position. So spark plug & voltage & pulse width, all being all the same, it appeared the culprit was the COP, & I had a faulty one, albeit, that it was actually functioning & working, but not at full strength.

When the trigger signal leading edge, is first applied to the COP, it doesn’t fire the spark plug.

The leading edge of the pulse, turns on the special transistor, inside the COP, that charges up the primary coil of COP transformer.  This can take several milliseconds. Once the coil is fully charged, that is the instance it is perfect to turn off the trigger signal. The collapsing magnetic field in the primary winding, induces a high voltage in the secondary coil, & that voltage jumps across the spark plug gap.  This is why the duration of the pulse to the COP, is so “critical”.  If the pulse is too narrow (shorter), the primary winding may not be fully charged, & the energy stored in the winding, will not be able to produce a spark strong enough.  If the pulse is too wide, then once the primary winding is saturated, the current will still be flowing.  However, as the primary winding is already fully charged, this additional energy, is just dissipated as heat, & the COP body will feel hot.  Obviously, running excessively hot, will impact on the long term reliably & efficiency of the COP.

I then remembered I had a small Hantek-CC AC/DC current clamp, in my possession, that plugs into the CRO, so I could actually see what the charging current was.

I hooked it up & measured the current drawn by the two COPs, where I had observed one had a “brighter” spark, than the other.

The one with the brighter spark, was indicating, that at the end on 3.2 millisecond trigger pulse, the current had risen to 11 amperes DC, at which point the spark was generated.

The one with the not so bright spark, was indicating, that at the end on 3.2 millisecond trigger pulse, the current had only risen to 8.0 amperes DC, at which point the spark was generated.

It just appeared that a 3.2 millisecond pulse was not long enough for this particular COP.

To investigate what the issue was, I modified the pulse widths of both COP drivers, to 4.0 milliseconds, & repeated the exercise.

Noticeably, both spark plugs now had arcs, that were of similar intensity.

The COP that was previous firing, at 3.2 msec, was now firing at 4.0 msec, but had fully saturated by 3.2 msec; & was flat lining until 4.0 msec, when it fired. (see below)

image.png.e1bd9ecf148564fadb7721df05c99c74.png

The COP that was previous firing, at 3.2 msec, but was only achieving 8.0 amperes current, was achieving  10.5 amperes, when it had been charging for 4.0 msec, when it fired. (see below)

image.png.6cd42be3b07a6174bb364f777caa99cd.png

I left them both running like this for 15-20 minutes, & you could feel the increase in COP body temperature, of the COP that was fully charged by 3.2 msec., but did not fire until 4.0 msec.

So there was no defect in these two COPs; it was just that they were different.  I smelt a rat !

I had a total of six (6) model 90919-02240   COPs.

I then tested them each individually, as above procedure.

Four (4) off required a 3.2 msec pulse to reach 11 amps, & be fully saturated, before firing.

Two (2) off required a 4.0 msec pulse to reach 10.5 amps, & be fully saturated, before firing.

I know there are fake components out there, & it looks like I’ve been caught with 2 off, with these “Toyota Denso” COPs.

image.png.4f56b63f210387e9a0c414fbf213a3fa.png

I looked at all six of them in detail, & the moulded markings all clearly say Toyota Denso, & made in Japan, & to the naked eye, look identical.

If these two (2) are counterfeits which I suspect, they are very good ones, externally.

A few years ago, I got caught with counterfeit NGK Iridium spark plugs, where the only way to tell visually, is a slight difference in the printing on the box.

I rang NGK, here in Australia, & they gave me the name of a guaranteed official retailer of NGK spark plugs here in Brisbane. 

https://www.evolutionm.net/forums/evo-engine-turbo-drivetrain/689127-spotting-fake-denso-ignition-coils-cops.html

https://www.ngkntk.com/newsroom/blog/emea/fake-or-not/

Interesting that the guy in this article about the fake Denso COPs, measured the resistance of the coil & found it was “higher” than the genuine Denso product, which would correlate with it taking longer/slower to reach a full charge.

So I might just go & buy four (4) new Denso 90919-02240 COPs, & hopefully I obtain some uniformity in their performance.

So next update, will hopefully be with the system actually running on my 5K engine, as currently, it has a carby on it.

Cheers Banjo

Edited by Banjo
Link to comment
Share on other sites

Its a good thing you are that finicky!  Most people would just use them and wonder about a faint misfire now and then..  if it makes a difference at all.

I wonder if they are all genuine OEM and that is within the acceptable range of saturation times? How many Yaris owners would notice? You might take a portable test rig to your Toyota dealer and try them on the bench before you buy!

Link to comment
Share on other sites

Every millisecond is important, when it comes to timing & charging a coil primary winding, whether it be a single coil system, or a COP system, with one coil per cylinder.

Lets look at the maths of ignition timing.

image.png.5623d0d1493253603612bbf8a5881ec4.png

In a 4 cylinder engine, with a points/distributor based system, the dwell angle (period during which the points are closed & the coil primary winding is charging),  is pretty common, at around 45 degrees; depending on the lobe profile on any given distributor.   So if we relate that to crankshaft degrees, it would be 90 degrees, as the distributor only runs at half crankshaft speed.

90 degrees equals exactly 1/4 of a revolution of the crankshaft.

If the engine is at idle at 1000 RPM, then one revolution of the crankshaft takes 60,000 milliseconds, (millisec in a minute) divided by 1000, & equals 60 milliseconds.  As 90 crankshaft dwell angle is a quarter of one revolution, then the dwell period would be 15 milliseconds.

Now repeat the calculation for when the RPM is mid range, at say 2500 RPM.

60,000 / 2500 = 24 milliseconds.  90 degree is 1/4 of that period & is 6 milliseconds.

For 5000 RPM the figure is (60,000 / 5000) = 12 milliseconds.   90 degree is 1/4 of that period & is 3 milliseconds.

Unfortunately coils don’t charge in angles. They charge in time.  So in a 4 cylinder engine, at 5000 RPM; if the coil was not able to full charge enough in that given period, the ignition coil performance, would drop off, the higher the RPM progressed. So that was for a 4 cylinder engine.

If we repeat that exercise with a maximum dwell, for 6 & 8 cylinder engines, where the cam & crankshaft dwell angles are even less;, you can see why early engineers on 6 & 8 cylinder engines, dreamt up things like twin points & even dual distributors, to try & extend that dwell period, for charging up the coil. The real problem with a single coil is it has to charge up, & fire, before it can start to charge up again, ready for the next cylinder. That limits time available at higher RPMs.

One of the reasons for the COP design;  was that each cylinder had it’s own coil.  Their charging periods could effectively overlap, if necessary.

One of the reasons CDI became so popular, was that it overcame the dwell restrictions, altogether. A capacitor was charged up, by a much higher voltage than 12 volts (typically 200-300 Vdc), in less time, than it took 12V dc to charge a coil primary winding.

These are still very popular on high reving single & twin cylinder engines on ATVs & quad bikes, outboard motors etc.

https://en.wikipedia.org/wiki/Capacitor_discharge_ignition

They are pretty cheap on ebay, so I might get hold of one, & have a play with it.

There would be no need for dwell angle compensation, vs 12 volt battery voltage.  

Returning to the COP performance; it is more important that the COPs are matched, in terms of time to fully charge the primary winding of the COP’s coil.

There is only one dwell time vs battery voltage compensation table, in the engine ecu.  It would be totally unwieldly, to have one for each COP.

I’ve ordered another 4 off Denso COPs today, from the same source.  When I receive them, I’ll test each one separately, & see how close & matched their charging times are.  It doesn't really matter whether they are 3 msec, or 4 msec; as long as they are all the same.

Edited by Banjo
Link to comment
Share on other sites

Quote

I’ve ordered another 4 off Denso COPs today, from the same source.  When I receive them, I’ll test each one separately, & see how close & matched their charging times are.  It doesn't really matter whether they are 3 msec, or 4 msec; as long as they are all the same.

These have arrived now, & I've tested them all for dwell time required to reach full coil load amps.

I'm not sure whether these Denso COPs, I've purchased are genuine or copies.  However, whatever they are; their dwell times are all identical, as they must/should be.

The trigger wheel, dscribed in this thread, & it's associated decoding electronics, was fitted to the 5K test engine stand over the weekend, & it is all working perfectly, albeit, with a static 10-12 degrees of advance.

I had the use my little CPS (camshaft position sensor), instead of the one I had incorporated into the camshaft spocket/chain cover.  It was in the wrong position, so it was easier to use the other CPS sensor, built into an old cut down 3K dissy, as it can accomodate & place the camshaft position pulse, anywhere in the 720 deg cranshaft 2 revoloution cycle.

Just now building a proven circuit, for providing a load & advance map for RPM & Load compensation. I also intend to add a knock sensor to it, so that I can take advance to it's limits without any chance of serious engine damage.

image.png.4b9bb77184524ffd35c35f865aeea160.png

One of the disadvantages of using a COP; is that there are no longer any spark plug leads, to put the strobe timing light pickup onto.  Note my "workaround", by mounting no: 1 cylinder COP, upside down, & running a spark plug lead between the spark plug & the bottom tip of the COP.

I have seen a tester on the internet, & I belive you can buy them commercially, that senses whether a COP is firing, by just placing a "wand" on the top of the COP itself.  I should be able to build a "wand" that could then be used to trigger the timing light, so that the above worK-a-round, is not required/needed.

image.png.36a83af4c8358d19575c2a717771b2a2.png

image.png.5f0d546836e1b7367c26ad4cb84e1a1b.png

Cheers  Banjo

Edited by Banjo
Link to comment
Share on other sites

  • 2 weeks later...

So the trigger wheel/disc, with magnets, & it’s decoder, is now running the engine, by firing four (4) off COPs sequentially; albeit, at a fixed advance of 10-12 degrees BTDC. (as per pics in the previous post)

Next step to build an advance / retard controller.

I built my ignition controller, with a “mapped” advance retard curve, by revisiting a tried & proven programmable ignition system, designed by Silicon Chip magazine, way back in March 2007.  I say proven; as I have been using it in my KE30  2 door coupe, on a 4K-U engine, for years; with an Accuspark 3K dizzy Hall Sensor setup; & never had to touch it since, after I initially getting the advance mapping correct.

I looked on the Silicon Chip website on-line store, & they still had the programmed PIC micro-processor for this project.  I have built it up, in recent days, & tested it on the bench, & it appears to work well.

image.thumb.png.e44fc0c224e37c00a657a110f8c131b3.png

The programmable ignition controller, can accommodate 2 off 11 x 11 advance/retard maps, (for duel fuel applications) or a single 15 x 15 map, which is what I’ve used

There is no software, that communicates with this system, so a little hand controller, with an LCD display & some push buttons, is used to create the map.  It’s a bit laborious, but works well.

image.thumb.png.1644ea9acd9d9e9662ebfee2c19aa90f.png

I used Excel to create the map.

image.thumb.png.3c8beca5f8b13ebbf05f9d298ab14fe6.png

The MAP is a "little flat", to start with, but can be changed, during load testing, to optimise the advance setting, for various RPM & load ranges. 

image.png.4492ed1c93f39e38ca5f3bac52b3ba8f.png

 

I also limited the maximum RPM range, as my test trigger disc, & speed controlled electric motor on my bench, is not balanced; & the motor is only capable of 3500 RPM maximum.

 

image.thumb.png.d188d064234e3d630c3c1b540d7003ef.png

Once I get it on the engine & do some fine tuning, of the advance/retard map, I will be setting the advance as high as practically possible, without introducing “knock”, which could “spoil the party”.

Not wanting to do that, I’ve yesterday built a Knock sensor kit; again put out by Silicon Chip in June 2007.  (Silicon Chip still had the PCB in stock)

image.png.31e5887470ef398a2b8eeea4db9a7ce5.png

Knock is caused by detonation, or too much advance; or high engine temps; or lower fuel octane rating, than normally being used; & results in mechanical piston rattle within the cylinder, around TDC.

Modern cars all have a knock sensor, on the engine, that detects this piston rattle, & tells the ECU to back off the advance a bit.  Apparently, all “knocking” in engines, creates “noise/knocks” in a frequency band width of between 4.5kHz & 6.5 kHz.  The knock sensor itself, is basically a tiny microphone, listening to your engine. They typically use a piezo-electric sensor, which is attached to the engine block or head.

The “knock or detonation” sensor controller, is basically a “notch” filter that only looks at frequencies between 4.8 – 6.4 kHz. When detonation, or knock is detected; a signal is sent to the ignition controller. As knock only occurs around TDC, the controller only looks at the knock sensor output, around TDC & for several milliseconds after firing has taken place. That avoids any other engine noise, that gets picked up by the “knock sensor”.

The controller then automatically reduces the advance, between 0.5 to 6.0 degrees of advance, depending on the severity of the knock.

I could nip down to a wreckers, & pick up a knock sensor, but I notice they are not that expensive on ebay, ranging from around $ 20 upto about $ 80.00.  I prefer the screw-in type, rather than a bracket on the engine; as the sensor, then becomes part & parcel of the engine, & integral, to the block or head.

Next question is where to mount it.  My research indicates, that the preferred position is on the head some where.  Has anyone out there ever fitted a knock sensor to their K Series engine, & if so, where did you attach it ? My personal preference, would be to fit it, high on the engine block, on the opposite side of the engine, to the exhaust header.  I found a couple of threaded holes, behind the mechanical fuel pump, that appear to be roughly between cylinders 1 & 2.  A bit tight in there, as the mechanical fuel pump obstructs; but I’m using an electric pump, & that area, has a blanking plate.

image.png.41d345eb61986dc85a2082c315e956c2.png

Would welcome any suggestions.

Cheers Banjo

  

Edited by Banjo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...