Jump to content



- - - - -

My Ke20 Sedan


  • Please log in to reply
11 replies to this topic

#1 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 25 January 2012 - 06:50 AM

started work on my e20 in december. sourced an engine made modifications to the k40 box, k fly wheel and made engine brackets to suit the conversion

Attached Thumbnails

  • 04-03-11_0207.jpg
  • 04-03-11_0209.jpg

Edited by ke20sedan, 25 January 2012 - 07:11 AM.


#2 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 25 January 2012 - 07:15 AM

removed all the parts and some of the rust. Adapted the gearbox to suit the 20 valve. include machining out "K" fly wheel to fit the "A" crank and using a grinder to cut out a bolt hole in the gearbox to complete bolt up to engine.

Edited by ke20sedan, 25 January 2012 - 07:17 AM.


#3 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 25 January 2012 - 07:25 AM

With all the machining done, i used back the original clutch and pressure plat that came with the flywheel.
Decided to look inside the 4a-ge, found a lot of sludge and damage bearings.
Did some cleaning up and replaced the main and rod bearings and fitted up the engine. At the same time i service the gearbox.

Placed the engine and box in the car, then started to work on adapting the engine to suit the car.

tried coil packs on a 5a-fhe computer to run the 20 valve. in testing it seemed o.k, but gave problems during the real starting of the engine.
ended up trying a 4a-fhe computer as well. had a similar problem.
ended up dropping the coil pack idea for the time being.
ended up cutting a hole in the firewall and using the 5a-fhe computer to run the engine.
started the enging with this set up but later change to a 5e-fhe paseo computer to contol the vvt solenoid.

the engine limits at 7800. but seems to have some timing issues as it has poor fuel economy and breaks up at times.
working out solutions as i type. think its the distributor wiring.

all this is suppproted by a custom wire loom which seems to have an error with the rotary idle contol valve.

Attached Thumbnails

  • 04-03-11_0326.jpg
  • 04-03-11_0327.jpg
  • 04-03-11_1424.jpg
  • 04-03-11_1421.jpg
  • 04-03-11_0757.jpg
  • 04-03-11_1055.jpg
  • 04-03-11_1053.jpg
  • 04-03-11_1042.jpg

Edited by ke20sedan, 27 January 2012 - 06:59 AM.


#4 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 27 January 2012 - 07:05 AM

engine is not functioning right and i know the ecu is to blame. the 5e-fhe computer seems to be giving problems with the timing. an seems to dumping too much gas. a lot of unburnt fuel drips from the exhaust. i thing the ecu is stuck in closed loop. and keeps giving me code 41 (open or short with tps sensor) using 20valve tps, plan to try the 5e 3pin instead although i'm certain the auto 5e-fhe uses a 4pin tps

Edited by ke20sedan, 27 January 2012 - 07:05 AM.


#5 machg

machg

    Regular Member

  • Regular Member
  • PipPipPipPipPip
  • 439 posts
  • Online:18 Jul 2013 08:56 PM
  • Location:Hobart, Tasmania

Posted 27 January 2012 - 07:46 AM

I have a silvertop 20V running a standard 20V ECU on a modified loom. Makes great hp, uses very little fuel. Get the right ECU for the engine.
Cooking

#6 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 28 January 2012 - 02:34 AM

i have seen a blacktop on boost being run by a 4e-fte make 420 plus hp, no problems with his although i think his a piggy back combo. see persons using the blacktop ecu and dizzy to run volks wagon still no probs.




ended up finding the problem anyways. the distributer timing was throwing off the ecu. had the wires mixed up. since change starts a lot easier.


ps........ hate airflow meters thats why i opted for the 5e-fhe. in ja the airflow meters always seem to give problems and the20v airflows choke the engine pass 7500. (supported by researce of dynos)

Edited by ke20sedan, 28 January 2012 - 02:39 AM.


#7 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 28 January 2012 - 02:45 AM

machg had a AE92 levin 20v on the blacktop ecu was quite fuel efficient below 4000. (normal driving) more than a 4e starlet

Edited by ke20sedan, 28 January 2012 - 02:47 AM.


#8 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 01 February 2012 - 12:52 AM

did some research on the injectors, (although i already knew it) 20 valve injectors-2 ohms, 5e- fhe 14 ohms.
seems to be a conflict of interest given my current set up.
going to install resitor packs to remedy




the silver tops are 14 ohms according to my multimeter. so who is wrong. searching for someway to control the vvt with my current ecu

Edited by ke20sedan, 22 February 2012 - 03:45 AM.


#9 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 08 February 2012 - 04:33 AM

also found out that the engine is overheating. like an ass i totally blocked of the flow at the back of the engine with a plate. will have to design and build a nes plate to allow water flow at the back of the head

#10 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 08 March 2012 - 06:03 AM

drove out the car a couple times after i revised the ecu wiring a bit. certainly more agressive. better fuel economy as well.
after some more testing got the vvt to work with ecu. it activates as early as 4500 if you floor it. and as late as 6500 if the trottle is increased gradually. (based on acis criterior..... 4500 @60% trottle)
need to make adjustment to fuel pressure as its running a bit rich.

Edited by ke20sedan, 08 March 2012 - 06:06 AM.


#11 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 22 March 2012 - 07:29 AM

the car was runing really well. with my current setup was easily keeping pace with a supercharged 4a-ge ke30.
problems though, didi a crytal mod and during the testing chopped of the fly wheel bolts. somewhere around 9300 rpm or higher. getting some arp bolts before i test again.
thinking maybe the flywheel bolts were not torqued properly.
also built some custom headers to replace that crppy manifold

Edited by ke20sedan, 22 March 2012 - 07:30 AM.


#12 ke20sedan

ke20sedan

    New Member

  • Members
  • PipPip
  • 12 posts
  • Online:03 Feb 2014 02:26 AM
  • Real Name:russell

Posted 07 August 2012 - 08:37 AM

after going through a next set of bolts again. i reverted to the original limit and during a drift damaged the engine head braking all the valves in the no 1 cylinder including the piston.

baring that i have invested my time in a 3s beams in a hilux van. damn that engine is powerful. will be posting some pics of it soon.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users