Jump to content

Mason

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Mason

  • Rank
    I'm new here

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hey Banjo! I’m in Sydney, yes unfortunately the rust is an ongoing issue. I am keen on getting it sorted as I’d rather not let it fall apart any longer haha. Keen to hold onto her for as long as I can. Luckily for me it’s all panel, floor pan is extremely solid which is a relief. Ahh unfortunately not. Judging by some old service receipts it’s gone around the clock once at least. My interior suggests it’s more likely to be 173,XXX, can’t imagine it’s gone around twice as I’ve got no wear on the inside at all. Someone went ahead and already did that for me before I purchased. Very happy to have the 5 speed for the freeways. cheers!
  2. For the passed 5 years I have dailyd my 36 wags. Was long overdue for some love but between living out of home and working full time it never quite got the love it deserved. Thanks to COVID I didn’t have to worry about either of those things. So, here’s a pretty comprehensive list of all the work I’ve done over the passed couple of months. Only a couple things left to do to the rear springs then I’m sorted. Note I’m not a mechanic at all, just a hobby. Had to pop her in for a rust quote the other day. Hopefully it doesn’t stop my heart. Thanks! 08/04/2020 - new leads - new spark plugs - new spark plug seals - new rotor - new coil - new resistor - new dizzy cap -new fuel filter -new cam cover gasket -$250 total 15/04/2020 -carb service kit installed $80 -new power valve installed $80 -new adapter gaskets $7 20/04/2020 | 73083kms -gearbox oil change $90 22/04/2020 New gear shift boot $36 28/05/2020 New rear main seal and gasket $40 New sump gasket $30 New alternator $180 New clutch kit $136 Cleaned engine 8/06/2020 new alloy radiator $240 New heater hoses New oil New coolant 9/06/2020 new oil pressure switch $14 Two new lower ball joints $100 Front sway bar link washers $20 11/06/2020 Second hand front strut inserts -6 months old/new springs/dust covers/strut mounts 12/06/2020 HEL brake lines installed $280 New brake fluid $22 New tyres $170 15/06/2020 second hand rear shocks $33 - 1-2 years old Rear shock upper bushings Rear sway bar bushings and washers
  3. Hey! Just following up on this one again, after all the headaches it was the external voltage regulator. So problem solved. One day it would be good to upgrade the alt but as I had already purchased one I guess for now it will stay how it is.
  4. Hey, Replaced the old alternator with a new one, didn't solve my charging/blowing fuse issue. Found a bad wire on the external voltage regulator and soldered that back together. That seems to have fixed my problem. No more charge light and no more blown fuses, and the battery is charging, however, now I'm getting pulsing lights all throughout the car and my charge voltage is jumping from 13-15 randomly (also affects idle?) So I am thinking the reg is bad. Thanks, Car also did run fine without the engine fuse - just no charge Also car wiring has definitely been hacked into in its lifetime - unfortunately...
  5. Heyo, I have a '78 ke36 that gave me the battery discharge light a couple of weeks ago. I noticed it had blown the engine fuse as well. Battery was reading 12.~ volts but wasn't getting charge when the car was running. The old man and I ran some wiring continuity and what we checked around the alternator seemed fine. We did deduce however that the engine fuse stopped blowing when the alternator itself wasn't plugged in, could be its just completing the circuit though. When we plugged the alt back in with an engine fuse in the box and cranked the car it made an ugly sound from the alt then blew the fuse again. So we decided it was probably a dead short in the alt, I put a new alt in last night and got a jump start, bummer, discharge light still there, blew another engine fuse as well. The discharge light did go away for a few minutes which was weird but then came back. So I am at a bit of a loss with this one. Yet to pull wiring apart and have a search but just wondering if anyone has had any similar experiences and would be open to shedding some light. Also please note I am an wiring noob...Thanks Mason.
×
×
  • Create New...