Jump to content

ke25 dash wiring issue


ESTANG
 Share

Recommended Posts

Hello, first of all i need to apologize for this post since its kinda dumb because my dumbass forgot to take photos.

So, i was taking apart my ke25 dash so i replace the odometer with the one from my ke20, the annual inspection is coming up and i want to permanently have the ke25 tach in my ke20, the issue I'm having is the position of the cables of the tach, since i forgot them, i took a look at the ta22 dashes that i have, but all of them seem to be different. If anyone could tell me the position of the cables i would be really grateful .

For better understanding I attached some photos.

Thank you

bbb820c2-2b1a-4ad4-a040-cc13bf7d6d49.jpg

4066ec98-e961-4325-ac15-54e0a18b8908.jpg

Link to comment
Share on other sites

Members dont see this ad

Hi Joao, 

               This shouldn't be too hard.  There are only three (3) wires from the tacho to connect.

One will be +12V; one will be ground/earth/chassis; & one will be the tacho input signal. 

The ground/earth/chassis connection, will usually be a black wire,  or white with black stripe, as they are the Toyota wiring colour standards.

It looks like the black wire (already connected) is correct, as there is no where else it could connect, because of the black wires length.

You could check this by powering the dash assembly & testing with a multimeter or test lamp, that the point where the black wire is already connected is ground.

I am guessing that the black wire with the yellow stipe will connect to the terminal marked IGN 12V.  The tacho will only be powered when the ignition is "ON", & the remaining  white wire with black strip, is not long enough to reach that point.  However, there is always the possibility that the tacho is powered by the 7V connection, & either of these two wires would reach that point.  It appears the input is connected to the unmarked termination point, directly above the Japanese Toyota symbol, in your first photo.

All this depends on whether the rear PCB of the KE20 & KE25 dashes are laid out the same. I'd be putting the tacho back into the dash panel, you removed it from, & connect it up as it was. Then take note of which wires colours were connected to marked terminals, like +12v or 7V etc.

Unfortunately, I don't have a KE20/25 dash here I can check this out.  Try what I have suggested, & if that is not successful, come back, & we'll research this further.

Cheers Banjo

 

Edited by Banjo
Link to comment
Share on other sites

I just found an olde KE20/25 wiring diagram.  It has a tacho shown.  According to the wiring diagram the white wire with the black stripe goes to ground/earth/chassis.   The black wire with yellow stripe, goes to 12 volts supply on the fuse block.  Actually on my wiring diagram marked as simply a "yellow" wire.  The black wire goes to the "points" -ve terminal on the ignition coil.

So power up the dash, & check out which terminal is ground, & you should be away.

Trust this assists.

Cheers Banjo.

Edited by Banjo
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...