Jump to content

Search the Community

Showing results for tags 'speedo cluster'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • rollaclub.net
    • KE70.com
  • Rollaclub Technical
    • Automotive Discussion
    • General Mechanical
    • Motorsport
    • Car Electrical
    • Car Sound
    • Engine Conversions
  • Rollaclub Rides
    • Rollaclub Rides
    • Rides - non-Toyota
    • The Inner Sanctum
    • Did it Myself
  • Rollaclub Social
    • Rollaclub Social (Off-Topic)
    • Rollaclub Regional
    • News
    • Forum Support
  • matespace
    • Automotive Catalogues and Specials:
  • Market Place
    • Site Sponsors
    • For Sale - Car Parts
    • For Sale - Cars - Toyota ONLY
    • For Sale - Other (non-automotive)
    • Wanted to Buy
    • Looking for Work

Blogs

  • Best of Rollaclub
  • TOMsGPTurbo's Blog
  • Slant to Flat Conversion
  • visuli's Ke 20 Blog
  • The Silvia
  • LJMC-KE20's Blog
  • jimmy5det's Blog
  • Chadwick's Blog
  • 77KE30CS' Blog
  • deddy2012's Blog
  • little help please
  • oquinton's Blog
  • balico's Blog
  • KE72 Wagon
  • ke70 coilovers?
  • FAQTMU's Blog
  • rolla_van93's Blog
  • JJke55's Blog
  • Tezza15's Blog
  • nana_car_67's Blog
  • sweetke55's Blog
  • 78KE35
  • respect55's Blog
  • ZacKE70's Blog
  • HaydenRolla's Blog
  • HaydenRolla's Blog
  • HaydenRolla's Blog
  • *SErolla's Blog
  • Ke35 Hardtop
  • haydzzz's Blog
  • boomboom4786's Blog
  • rolesy's Blog
  • My38's Blog
  • GJM85's K Motor Blog
  • sharkboi's Blog
  • ke20rolla1971's Blog
  • Selling my rt80 corona
  • Crostek's Blog
  • Tweets ke30
  • SEM600's Blog
  • J-ROD's Blog
  • G0TRIC3?'s Blog
  • appsy's Blog
  • NEED A 22re STARTER MOTOR
  • The Kid's KE15
  • dirtyke29+1=30's Blog
  • rolla76's Blog
  • conmeow's Blog
  • corollninstyle69's Blog
  • Cleighton's T18
  • mazrotor's Blog
  • corolla_ke700's Blog
  • MartyJ's Blog
  • rolla_j's Blog
  • https://game-onlinetvchannel.com/colts-vs-titans/

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


How did you find us?


Real Name

Found 1 result

  1. Hey team need some help tried looking all over the net and can't find what i need, Currently trying to install my speedo cluster into my 1981 AE70 sedan but have a slight problem. There is ment to be 3 connector plugs leaving the loom into the back of the dash like the first photo. In my car i have 2 of the 3 plugs but where i should have the 3rd one i have two smaller ones that don't fit in any kind of way and have me all confused on why they are there and what they would have been for(see second photo). Any ideas on how to fix would be awesome or if anyone has any type of wire diagram so i could try wire in a normal plug Cheers
×
×
  • Create New...