Jump to content
Sign in to follow this  
corollaart

electric fuel pump

Recommended Posts

Looking for a good safe ignition on power for electric fuel pump.

Around dash or ehgine bay,had a huge wireing melt down .not sure if it was fuelpump wirng or coil  wiring to much damage to be sure.

Yes i have a relay on pump ,and fuses.(been working fine for years)

4age ke55 carbs

 

Share this post


Link to post
Share on other sites
Members dont see this ad

Coil ignition would be the obvious one, use that to run a relay with coil and pump both on it. It depends on how you wired the 4AGE in to start with. Alty would be another, that has an ignition controlled feed. Wipers would be a bit out of the way, probably the passenger's kick-panel if its like a KE70. Indicators would all be inside the column, as would the accessories like lighter and radio.

Do you have an electric fan on it??  The slantys have a purple wire going from drivers side to passengers that was ignition controlled, I assume for the 4AC coil. Which loom did you get to repair it with?? KE55?

Share this post


Link to post
Share on other sites

Is it a pusher or puller pump?  If the former may want to consider relocating to the boot?

Share this post


Link to post
Share on other sites

Thanks Pete,Kieth,the pump is in the boot with relay ,been there for years.

Ive had a major wiring melt down in ehgine bay,from where i extended the coil wires from right to left inner guard.

Which also had taco wiring and oil sender and fuel pump power(from the coil)all melted so it was hard to find which wire caused the problem.

I'm trying to eliminate as much wiring to the coil as possible,have keeped all the replacement wiring seperate from main loom just in case.

There where no shorts ,as ive removed the loom (twice)unwraped every think and re wrapped it.the light wiring is un touched and works fine.

i m suspecting ive used to light of wire in one of these and it finally give in.my guess.

i got it to run yesterday ,with fuel pump power to a blue red wire at ignition switch just loose to see if my new wiring in the ehgine bay caught on fire,it didnt.

Still have to find a 12v to hook the charge light to ,maybe the coil positave but I'm very weary of this coil now..

thanks rob

Share this post


Link to post
Share on other sites

Here's the KE70 setup, it must be very similar. That black/orange on IGN2 does the 'running' voltage to the coil and is also a feed to the engine fuse. If your 55 had a 12V coil you probably don't have that wire, it would all run off the BY IG1.

692160335_KE70ignwiring.thumb.jpg.020efef9b6b80c627a7d89e6593d1a7a.jpg

Are you running a newer alty with an internal regulator? If the 55 had an external regulator it would look more like this, the USA T motor.

241800833_wiringextreg.thumb.jpg.1704d633c034fb3aeef83f454f16664c.jpg

In the end, just hunt around with a multimeter until you find an ign positive and trace it back to see what its for.  Hook that onto a relay with power from the battery or alty, and feed it to whatever needs to be ignition-controlled.  At the worst, run a new wire from the ignition key into the engine to feed a relay. I've put my coil onto a relay with the 4AGE, it cuts down the current that the coil feed carries from the key right around the engine bay, just like yours. Of course when the relay burns out I'm in the same boat.

 

Share this post


Link to post
Share on other sites

Kieth yes so the main feed to the coil ,you have a relay next to the coil?i wonder how many amps it has to cope with?ive replaced it with good quailty 50amp wire.

I also have a smaller red wire that comes from the ignition sw as well,

I'm running a 4age alternator,3pin so my next stupid question ,post-6-1174380195.jpg  

 

I have the S wire looped to B I have the light conected to exsisting wiring,But the IG wire was run in the burnt loom right back to ignition switch .

Can i put this wire to coil positave???instead of running it back to ignition??to mininmise more wiring 

thanks

 

 

 

Share this post


Link to post
Share on other sites

I expect the coil will not draw more than 10amps, that leaves about 10amps for other uses in their usual 20amp relay.

Here's a handy diagram of wiring an alty in- Its illustrating why jumping the S onto B is not ideal, although I've done the same and don't seem to suffer from the drop in voltage at the battery.

389179228_wireanalty.jpg.1818c357de4358b0d374479cba373470.jpg

You can see you need the ignition light to be controlled by the ignition switch, and that is happening somewhere under the dash. Then a wire goes from the lamp to the alty and earths out when its not charging, lighting the lamp. That's the purple circuit below. Keep that, and if you want to jump across the orange line from coil to alty, make sure there is a fuse in it. That line activates the alty, the main current of power from the alty is the blue line going to the fusible link line and into the battery and car as a whole. The fact that Toyota didn't run the alty off the coil wire means there's probably a reason not to, but I don't know what that is...

1847459191_RobsWiringAltyUSA.thumb.jpg.f1b89a44e5e441fd00381ef5d9f30106.jpg

Here's the factory wiring setup from these guys-

http://wilbo666.pbworks.com/w/page/39441708/Toyota%20Alternators

979311748_Toyotaaltywiring.thumb.jpg.e87e0048fa8a848989157c26ba94f514.jpg

They run a 10amp fuse in the line from Ign to Alty. If the IC regulator in the alty blows up you don't want the same problem again.

 

 

Share this post


Link to post
Share on other sites

Well just a up date ive fused IG wire to coil to alt.Ive fused the L wire from Ignition switch.

The only wire to coil thats not fused is the original heavy wire to power coil,which i guess i proberly should do as well.

Ive still have S looped to B as its worked fine before.

Its not pretty,but have to get rally rego in next couple of weeks ,hence a bit of rush.

Then i can try tidy it up after,its running fine atm .

I would love to completely do the engine,starter alt wiring from scratch,as the light side works fine.

But where to start and stop !!!!and I'm not that confident to tackle a task that big .

Thanks for help Kieth and Pete

Fire Extinguisher Service, Suppliers, Company Sydney | Fire Safe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...