Jono.C

1967 - Wagon Build

Recommended Posts

So i got a message from guy that said "I have a 67 station wagon, Very rough"..

 

After a quick call, with cash in hand i went and had a look... A 1st gen wagon has been something i've dreamed of since i can ever remember.. And the thought of one being so close to me for so long... I had to have it.

 

It was rough... The car had sat in a long grass paddock since early 1990's.. And it showed. Every panel dented, rusted.. Hyper extended door, rat piss interior "Ran when parked"... I had to save it.

 

I paid the man, Organised a truck and it arrived the next day.

 

So, Here it is.. My 1967 Ke16!

 

IMG_8012_zpsmdls2jxc.jpg

 

IMG_8017_zpsvwntc0rh.jpg

Edited by Jono.C

Share this post


Link to post
Share on other sites
Members dont see this ad

Those chrome bumpers are quite straight by the look of it and most of the other trim is there.

 

How's the rust in the parts that can't be unbolted?

Share this post


Link to post
Share on other sites

I wouldn't say easily restorable, there's a lot you can't see in photos but it is fixable.

 

Floors have a little rust in them, both sills have quite a few rust holes to tend with but the rear pockets behind both back wheels are just a mess and will need to be cut out completely up to the body line and then reformed..

 

 

I've got it running and driving now next step is fix rear brakes and disk swap the front. I'll be using my green sedan for donor panels to get this into paint faster

Share this post


Link to post
Share on other sites

Thought I'd throw up a few more photos from the first day of owning it. Karchered the entire car, threw some Mazda 626 wheels on to roll it around and threw another bonnet on/ started fixing the front end

 

20170203_174228_zpsuhecomtv.jpg

 

 

20170203_185918_zpsjztvdfrv.jpg

 

And heres the motor situation, a bigport 3k. "Ran when parked" required new starter, dizzy was 1 tooth out and firing order was wrong. Now starts and runs fairly well

 

 

20170203_184429_zpsyel4f2u2.jpg

 

 

 

 

Share this post


Link to post
Share on other sites

Didn't know 10's had the battery on the drivers side. Leaves a nice void behind the passenger side headlight.....

  • Upvote 1

Share this post


Link to post
Share on other sites

I'm almost wondering whether it'd be easier to relocate battery, J pipe across to drivers side.. be easier for dump routing and cooler etc

Share this post


Link to post
Share on other sites

Maybe seek untubbed_20's input on that. Without adequate bracing and maybe still with, its a lot of weight and leverage hanging off the exhaust manifold. You could try and find an mx6 cooler like mine rather than some wanky cross flow aftermarket thing.

Share this post


Link to post
Share on other sites

One sill stripped back, now sanded in primer. Probably worse than i was expecting lol roughly 2 dozen holes to weld up, could be worse though!

 

20170210_183119_zpsbvnooxll.jpg

Share this post


Link to post
Share on other sites

I'll grab some during the week, taken a week off work end of the month to try and get a fair bit done before winter (no shed life)

 

Interiors pretty much throw away for the most part.. It was used to transport gearboxes etc for majority of its life so its full of oil and grease, plan is to pressure wash it and go from there

 

I was missing headlight surrounds and tail light chrome but thankfully someone on the rollaclub facebook page sorted me out!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now